Child pages
  • Compatibilité des Portlets uPortal-Esup V4
Skip to end of metadata
Go to start of metadata

Liste des portlets testées par les membres du GT Esup-V4 sur un uPortal 4

Nom de la portlet

Version(s) de la portlet

Version(s) du socle uPortal

Fonctionne ?

Modifications réalisées pour fonctionner ?

Commentaires

CalendarPortlet

embarqué par uPortal

4.0.3

Oui

-

-

WebProxyPortlet

embarqué par uPortal

4.0.3

Oui

-

-

SimpleContentPortlet

embarqué par uPortal

4.0.3

Oui

-

-

WeatherPortlet

embarqué par uPortal

4.0.3

Oui

-

-

BookmarksPortlet

embarqué par uPortal

4.0.3

Oui

-

-

email-preview

embarqué par uPortal

4.0.3

Oui

-

-

mailportlet

rel-2.0.0-alpha-7

4.0.3

Oui

-

pour infos, on utilise une version patchée par nos soins pour le proxy cas ...

EsupTwitter

0.6

4.0.3

Oui

-

-

EsupFileManager

2.1.0

4.0.3

Oui

-

La 2.0.0 n'est pas compatible.
On utilisait dans le controller un request.getAttribute("javax.portlet.response") pour récupérer l'objet response ... cela renvoie null maintenant avec l'implémentation spring utilisée par uPortal pour portlet 2.0
Je ne sais pas si c'est un bug (par rapport aux spécifications JSR 286) -> on a changé le code d'EsupFileManager pour que ça passe.

EsupHelpdeskViewer

1.1.0

4.0.3

Oui

-

-

EsupSympa

4.0

4.0.3

Oui

-

-

EsupLecture

2.0-RC7

4.0.3

Oui

-

Ne pas prendre le war, le construire via les sources (subversion) par la commande :
mvn -P portlet2Development clean package

Esup-Annuaire2

 

 

 

 

 

Esup-Messages

 

 

 

 

 

Esup-SifacMissions2

 

 

 

 

 

AjaxNotepadPortlet

 

 

 

 

 

esup-agent

~  0.0.6 pacthé

4.0.4

Oui

Cf paragraphe spécifique concernant les portlets jsf esup-commons V1

 

esup-cil

 

 

 

 

 

esup-helpdesk

3.29.7

4.0.4

Oui

Cf paragraphe spécifique concernant les portlets jsf esup-commons V1

Le WebService Axis EsupPortail est ici nécessaire - a été adapté et ajouté dans le GIT interne RUNN EsupV4/uPortal4 ...

esup-mondossierweb

~ 0.1.7 patché

4.0.4

Oui 

Cf paragraphe spécifique concernant les portlets jsf esup-commons V1

 

esup-portlet-sympa

4.0

4.0.4

Oui

-

-

FacebookPortlet

 

 

 

 

 

esup-news

0.2.1

4.0.4

Oui

cf "important note" dans

http://www.esup-portail.org/display/ESUPNEWS/Installation+guide

 

RssPortlet

Embarquée avec le portail

4.0.4

Oui

 

 

simple-rss-portlet

1.1.0

4.0.4

Non

Même modif dans le web.xml que pour les portlets V1 ECV1

... on récupère une exception lors de l'accès à l'interface de configuration avancée ...
à débuguer ...

tabbed-search

trunk - rev 26004
patché

4.0.4

Oui

 

 

Problèmes rencontrés

sur toutes les portlets ...

Problème sur toutes les portlets (??!) : impossibilité dans l'interface graphique de modifier les préférences de la portlet "portlet.xml Preferences" ??!

-> fonctionne en 4.0.4 :-)

portlets jsf (esup-commons)

En EsupCommonsV1, le packaging des war incluait directement la dépendance au containeur de portlets pluto Version 1.x
Cela permettait de ne pas avoir besoin de la commande uPortal "ant deployPortletApp" pour déployer la portlet.
Mais ça a l'inconvénient d'être lié à pluto 1.x (et ici à portlet 1.0)

Cette dépendance ne se fait qu'au niveau de web.xml

Pour pouvoir faire fonctionner une portlet "standard" sur un portail utilisant un conteneur de portlets spécifique, seul le web.xml est à modifier.
C'est d'ailleurs tout l'intérêt de la commande uPortal "ant deployPortletApp".

Pour esup-agent (pris en exemple ici), la modification du web.xml pour pour pouvoir le faire fonctionner sur un uPortal4 est la suivante :

diff -r 096aa9087998 esup-agent/webapp/WEB-INF/web.xml
--- a/esup-agent/webapp/WEB-INF/web.xml	Fri Mar 23 11:26:07 2012 +0100
+++ b/esup-agent/webapp/WEB-INF/web.xml	Fri Mar 23 12:12:45 2012 +0100
@@ -179,22 +179,12 @@
 	<servlet>
 		<servlet-name>esup-agent</servlet-name>
 		<servlet-class>
-			org.apache.pluto.core.PortletServlet
+		  org.apache.pluto.container.driver.PortletServlet
 		</servlet-class>
-		<init-param>
-			<param-name>portlet-class</param-name>
-			<param-value>
-				org.apache.portals.bridges.portletfilter.FilterPortlet
-			</param-value>
-		</init-param>
                 <init-param>
                         <param-name>portlet-name</param-name>
                         <param-value>esup-agent</param-value>
                 </init-param>
-		<init-param>
-			<param-name>portlet-guid</param-name>
-			<param-value>esup-agent.esup-agent</param-value>
-		</init-param>
 		<load-on-startup>1</load-on-startup>
 	</servlet>
 	<servlet-mapping>

Librairies EsupCommons, portlet-bridge ...

Reste cependant que certaines classes, notamment EsupCommons, présageaient +/- moins de l'implémentation faite par pluto 1.x

On peut donc avoir des exceptions du type :

Caused by: java.lang.ClassCastException: org.apache.pluto.container.impl.RenderRequestImpl cannot be cast to javax.servlet.ServletRequest
        at org.esupportail.commons.web.tags.PageTag.setProperties(PageTag.java:190)

... exceptions +/- difficiles à corriger ...

L'exception ci-dessus a été provoqué avec un esup-agent sur un uPortal4.

La ligne 190 de PageTag.java d'esup-commons concernait simplement la prise en compte d'un paramètre de langue ... paramètre inutile pour esup-agent.

-> on a simplement commenté cette ligne 190, ça semble fonctionner pour esup-agent ainsi ...

  • No labels

1 Comment

  1. Apropos de PageTag.java,

    je pense que c'est complètement inutilisé : ça concerne JSTL (http://stackoverflow.com/questions/6126542/how-to-set-jstl-locale-from-java-code) que l'on n'utilise pas à ce qu'il me semble.