Child pages
  • Compatibilité des Portlets uPortal-Esup V4.3
Skip to end of metadata
Go to start of metadata

Liste des portlets testées ou que l'on se propose de tester sur un uPortal 4.3

En cours ... toute contribution est la bienvenue !!

Nom de la portlet

Version(s) de la portlet

Version(s) du socle uPortal

Fonctionnel ?

Modifications réalisées pour fonctionner ?

Commentaires

CalendarPortlet

embarqué par uPortal

4.3+

oui

-

bien en respondr (smile)

WebProxyPortlet

embarqué par uPortal

4.3+

oui

-

attention changement de configuration en v2...

https://wiki.jasig.org/display/PLT/WebProxy+Portlet+v2+Configuration

https://wiki.jasig.org/display/PLT/WebProxy+Portlet+v2+Gateway+SSO

SimpleContentPortlet

embarqué par uPortal

4.1.2

Oui

-

Très bien en respondr (smile)

WeatherPortlet

embarqué par uPortal

4.1.2

Oui

-

Très bien en respondr (smile)

BookmarksPortlet

embarqué par uPortal

4.3+

Oui

-

Très bien en respondr (smile)

email-preview

embarqué par uPortal

4.3+

Oui

-

Incompatible avec le responsive design
Correct avec le thème respondr - mériterait d'être amélioré tout de même. 

Travail fait en cours à l'UPMC :

Pull Request Mergée sur Apereo en fev 2017

PR : https://github.com/Jasig/email-preview/pull/70 avec ça Trés bien en respondr (smile)

ContactsPortletprojet Jasig 1.0.64.3+oui bug à l'affichage Travail fait en cours à l'UPMC : petit patch CSS pour faire ressembler du jQuery UI à du bootstrap... Trés bien en respondr (smile)

EsupTwitter

0.13

4.3 +

Oui

-

L'affichage reste très correct avec le thème respondr

Trés bien en respondr (smile) : arrivée en PR : oct/nov 2016 avant Mai 2017

https://issues.jasig.org/browse/ETPLT-7

EsupFileManager

Future 3.1.0

4.2.0

Oui

-

Fonctionnel en gardant la vue mobile de la portlet pour les mobiles - pour le thème respondr, une adaptation a été réalisée dans la version 3.1.0 d'esup-filemanager.

Travail en cours à l'UPMC

EsupHelpdeskViewer

1.3.1

4.1.2

Oui

-

Pas très joli avec le thème respondr - une couche de CSS est nécessaire.

EsupLecture

3.0.0

4.1.2

 

 

-> arrêtée ? gros pb avec la version Angular...

en attendant une clarification sur le projet, une alternative maintenue : https://github.com/GIP-RECIA/esup-lecture en spring-mvc/jsp

AjaxNotepadPortlet

 

4.1.2

 

 

 

esup-agent

1.0.1

4.3 +

Oui

  • Url svn sourcesup libs esup-commons
  • web.xml pour portlet 2.0
  • patch PageTag.java (PortletBridge)

Pas très joli avec le thème respondr - une couche de CSS est nécessaire.

Travail en cours à l'UPMC : he oui... va être bientôt en responsive bootstrap et tout... (big grin)  arrivée en PR nov 2016

-> avec le passage à siham, ne devrait plus trop évoluer. 

esup-cil

 

4.1.2

 

 

 

esup-helpdesk

3.29.7

4.1.2

 

 

-> portlet ne sera pas portée en RWD pour Respondr

esup-mondossierweb

~ 0.1.7 patché

4.1.2

 

 

Esup-MDW3 en mode servlet, compatible mobile -> portlet ne sera pas portée en RWD pour Respondr

esup-portlet-sympa

5.0

4.3 +

Oui

 Trés bien en respondr (smile) v. 5.0 compatible mutlicolumns (thumbs up)

esup-news

0.2.1 (utiliser code de la branche master)

4.3 +

Oui

  • Nettoyage des taglib
  • Désactivation de l'outil js de saisie des dates via un "calendar" (jscalendar-1.0)
  • Application de patch de compatibilité java 7-8-9 dans les lib spring
  • Selon version tomcat 8 : export JAVA_OPTS="$JAVA_OPTS -Dorg.apache.el.parser.SKIP_IDENTIFIER_CHECK=true"

Bien intégré

RssPortlet

Embarquée avec le portail

4.1.2

 

 

 

NewsReaderPortletEmbarquée avec le portail4.3+Oui Trés bien en respondr (smile)

simple-rss-portlet

1.1.0

4.1.2

 

 

 

tabbed-search

trunk - rev 26004
patché

4.1.2

 

 

 

esup-annuaire2trunk - rev 3384.1.2Non - NullPointerException Contournement : le mettre en servlet -> portlet ne sera pas portée en RWD pour Respondr
FeedBack-portlet 1.0.2-SNAPSHOT4.3+ oui 

Très bien en respondr (smile) avec cette PR https://github.com/Jasig/FeedbackPortlet/pull/8 compatible multicolumns (thumbs up)

Pull Request Mergée sur Apereo en fev 2017

Problèmes rencontrés

Anciens problèmes

Les problèmes rencontrées en 4.0 sont malheureusement toujours d'actualité pour certaines portlets : ces portlets n'ont pas proposé de mise à jour depuis.

Aussi, référencez-vous également à la page Compatibilité des Portlets uPortal-Esup V4.

Nouveaux problèmes

JDK1.7

Certaines portlets un peu anciennes peuvent ne pas compiler en JDK 1.7 simplement parce-que les fichiers .java sont encodés en iso-8859-1 et que votre compilateur s'attend à trouver de l'utf-8.

De type "Warning" en JDK 1.6, ce problème est maintenant remonté comme Error et bloque la compilation à partir de JDK 1.7.

Voyez cette entrée stackoverflow à ce propos : http://stackoverflow.com/questions/4995057/unmappable-character-for-encoding-utf-8-error

Le plus simple ici est de convertir ces .java en utf-8 simplement :

find . -name "*java" -exec recode iso-8859-1..utf8 {} \;

On a pu constater ce problème sur les portlets suivantes : 

  • esup-agent
  • esup-cil
  • esup-mondossierweb (corrigé en version 2.6.1)
  • esup-helpdesk

 

...

 

  • No labels